Author Topic: 06 STI Hesitation + Idle Problems..  (Read 384 times)

February 09, 2016, 12:38 AM #0

valeeraa Offline

  • Regular Member
  • Posts: 148
  • Join Date: Jun 2012
    Location: Winnipeg, Manitoba
  • Real Name: Sani (Sunny)
  • Vehicle: 2006 Aspen White WRX STI
  • Reputation Power: 3
  • valeeraa has no influence.
Alright.. Here's the run down.. Changed the tranny fluid, rear diff fluid and oil change Jan 28. January 31 and Feb 1, i noticed a slight problem while cruising.. It felt a little hesitant after work feeling like the car was pulling you back and releasing every few seconds. Plugged my Accessport in and looked up the A/F ratio, and holy eff.. It was going from 11 - 20 on cruise and during idle.

https://vid.me/UAxI

This video was from Feb 1. And to this day it's still going on. No CEL happening and also changed my MAF sensor and realized that wasn't the problem. Spark plugs was next on the list to change but I can go changing everything and realize that it's still causing the same problems. I was wondering if anyone would have any idea what would be going on? Or if any Subaru owners have any knowledge of what's going on?

Here's a forum on what this guy found on his. But I'm sure it could be anything..
http://forums.nasioc.com/forums/showthread.php?t=1789829

Was going to change both O2 sensors, but wow, that isn't cheap.
 :'( :'( :'( :'(

    Top Tier Imports

    06 STI Hesitation + Idle Problems..
    « on: February 09, 2016, 12:38 AM »

    February 09, 2016, 09:43 AM #1

    Igor Offline

    • Posts: 5,963
    • Join Date: Mar 2012
      Location: Winnipeg
    • Real Name: Igor
    • Vehicle: 2014 Subaru WRX STI Sport Tech
    • Reputation Power: 221
    • Igor is awe-inspiring!Igor is awe-inspiring!Igor is awe-inspiring!Igor is awe-inspiring!Igor is awe-inspiring!Igor is awe-inspiring!Igor is awe-inspiring!Igor is awe-inspiring!Igor is awe-inspiring!Igor is awe-inspiring!Igor is awe-inspiring!Igor is awe-inspiring!
    Did you check to make sure all your vacuum lines are on tight and that you don't have a leak somewhere?
    2000 Acura Integra GSR - Sold
    2014 Subaru WRX STI Sport Tech

      February 10, 2016, 12:30 AM #2

      awd_ftw Offline

      • Regular Member
      • Posts: 180
      • Join Date: Jul 2014
        Location: Winnipeg
      • Real Name: Ken
      • Vehicle: '98 ver4 gf8 STi, '10 subaru impreza 2.5i
      • Reputation Power: 7
      • awd_ftw has no influence.
      I had an issue like this. I found the rubber hose from my manifold to the FPR dry rot and cracked. Could also be a clogged fuel filter?


        Top Tier Imports

        06 STI Hesitation + Idle Problems..
        « Reply #2 on: February 10, 2016, 12:30 AM »