Author Topic: Need help with GC8 and HID's  (Read 1471 times)

July 27, 2016, 09:59 PM #0

Jmacs Offline

  • Regular Member
  • Posts: 212
  • Join Date: Jun 2012
    Location: Winnipeg, Manitoba
  • Real Name: Julian Macaraeg
  • Vehicle: GT86 2013 - Whiteout // AE86 1987 Panda
  • Reputation Power: 4
  • Jmacs has no influence.
Okay this is gonna sound super stupid, but i'm having issues installing HID's on a 1998 Wrx Sti. I have made all the proper connections and have checked voltage at my battery and the connector on the passenger side of the headlight (12 V)
The issue currently is that my drivers side bulb does not turn on at all, but my drivers side bulb works perfectly fine. HOWEVER the passenger side bulb stays on regardless if the low beam switch is on or off ( so it is constantly on)

I've followed all the instructions on Lumens sight for installing the H4 Ballasts and High/low beam module and cannot get these things to work.  The normal halogen bulbs work perfectly fine high and low.

I have attached a video below of everything hooked up and the passenger side bulb running constantly without the keys and switch being turned on. Any help would be great, thanks!

https://vid.me/pOyV

EDIT: i'd like to add that there are DRL's on the vehicle , but this High/Low Module was supposed to act as a DRL light kit as well.
Last Edit: July 27, 2016, 10:03 PM by Jmacs

    Top Tier Imports

    Need help with GC8 and HID's
    « on: July 27, 2016, 09:59 PM »

    July 27, 2016, 10:25 PM #1

    #StreetFocus Offline

    • Regular Member
    • Posts: 1,561
    • Join Date: May 2016
    • Vehicle: 1974 Ford Maverick
    • Reputation Power: 84
    • #StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.
    quite possible the passenger side is wired wrong in the plug. but that seems odd being that the driver side works okay. I know a lot of the cheaper kits are sometimes wired wrong.

      July 27, 2016, 10:41 PM #2

      Jmacs Offline

      • Regular Member
      • Posts: 212
      • Join Date: Jun 2012
        Location: Winnipeg, Manitoba
      • Real Name: Julian Macaraeg
      • Vehicle: GT86 2013 - Whiteout // AE86 1987 Panda
      • Reputation Power: 4
      • Jmacs has no influence.
      Originally posted by #StreetFocus
      quite possible the passenger side is wired wrong in the plug. but that seems odd being that the driver side works okay. I know a lot of the cheaper kits are sometimes wired wrong.

      I should probably add that at one point I had both bulbs permanently on with switch being off as well.

      after pulling out the fuse the unit was working properly as well  lows and high only activating when key was in, but after driving for like 5 minutes i checked up to see if they were working or not and the hid's were completely off. I seriously have no idea at this point

      edit: this kit is a lumens kit from speedfactor if that helps
      Last Edit: July 27, 2016, 10:44 PM by Jmacs

        July 27, 2016, 10:45 PM #3

        #StreetFocus Offline

        • Regular Member
        • Posts: 1,561
        • Join Date: May 2016
        • Vehicle: 1974 Ford Maverick
        • Reputation Power: 84
        • #StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.#StreetFocus is a force to reckon with.
        Ah, well, then I can't help ya. Sorry bud!

          July 27, 2016, 10:59 PM #4

          Jmacs Offline

          • Regular Member
          • Posts: 212
          • Join Date: Jun 2012
            Location: Winnipeg, Manitoba
          • Real Name: Julian Macaraeg
          • Vehicle: GT86 2013 - Whiteout // AE86 1987 Panda
          • Reputation Power: 4
          • Jmacs has no influence.
          Originally posted by #StreetFocus
          Ah, well, then I can't help ya. Sorry bud!
          all good man!

            July 28, 2016, 12:07 AM #5

            Shier Offline

            • Posts: 1,442
            • Join Date: Aug 2012
              Location: Winnipeg
            • Real Name: Greg
            • Vehicle: 2012 STI -- RIP 2011 Genesis Coupe
            • Reputation Power: 56
            • Shier is on the verge of being accepted.Shier is on the verge of being accepted.Shier is on the verge of being accepted.Shier is on the verge of being accepted.Shier is on the verge of being accepted.
            It will never have enough power until I can spin all four wheels at the end of the straightaway in high gear.

              July 28, 2016, 01:03 AM #6

              Jmacs Offline

              • Regular Member
              • Posts: 212
              • Join Date: Jun 2012
                Location: Winnipeg, Manitoba
              • Real Name: Julian Macaraeg
              • Vehicle: GT86 2013 - Whiteout // AE86 1987 Panda
              • Reputation Power: 4
              • Jmacs has no influence.
              Originally posted by Shier
              @WinnipegHID
              i might even just go down there see if they can figure it out, i'm stumped been looking over google for the past 2 nights lol

                July 28, 2016, 08:12 AM #7

                daveh Offline

                • Regular Member
                • Posts: 62
                • Join Date: Apr 2013
                • Real Name: daveh
                • Vehicle: Subaru
                • Reputation Power: 3
                • daveh has no influence.
                If you are putting these in a stock housing, just return them and do a bit of research on lighting. If you have an HID specific housing, then carry on. Subaru head light wiring is ground switched, so often a plug and play kit won't work.

                  July 28, 2016, 11:14 PM #8

                  WinnipegHID Offline

                  • Regular Member
                  • Posts: 40
                  • Join Date: Jan 2014
                    Location: Winnipeg, MB
                  • Real Name: Tom
                  • Reputation Power: 1
                  • WinnipegHID has no influence.
                  Thanks for the tag @Shier

                  @Jmacs two possible problems I can see:

                  1. The new Lumens relay harness H4 pins going into the factory H4 plug are incorrectly positioned. Older Subaru H4 systems are very problematic for HIDs since they used a switched ground to go from low beam to high beam. I don't deal with Lumens brand so I cannot confirm 100% that their H4 relay harness will work in your Subaru but we carry Morimoto bi-xenon relay harnesses that can do it. Try swapping the pins around on the Lumen relay harness to see what works properly, there are 9 possible positions the wires can be in, try all 9!

                  2. The HID bulb that is not working, either the bulb or ballast is dead or you simply have the connectors from the relay harness going into ballast flipped around, try flipping the connector a full 180 degrees to reverse the polarity of power going into the ballast.

                  OR stop by the shop for a diagnosis appointment and or full install :) 885 Redonda Street Unit 9
                  Automotive Lighting Upgrade & Repair Specialists

                  Explore & purchase products online SOON: www.winnipeghid.ca

                  - Custom Built Headlights
                  - HID Projector Retrofitting
                  - HID & LED Conversions
                  - Custom DRL Setups
                  - Headlight Lens Restorations
                  and more!...

                  885 Redonda Street Unit 9

                    July 29, 2016, 03:24 AM #9

                    Jmacs Offline

                    • Regular Member
                    • Posts: 212
                    • Join Date: Jun 2012
                      Location: Winnipeg, Manitoba
                    • Real Name: Julian Macaraeg
                    • Vehicle: GT86 2013 - Whiteout // AE86 1987 Panda
                    • Reputation Power: 4
                    • Jmacs has no influence.
                    Originally posted by WinnipegHID
                    Thanks for the tag @Shier

                    @Jmacs two possible problems I can see:

                    1. The new Lumens relay harness H4 pins going into the factory H4 plug are incorrectly positioned. Older Subaru H4 systems are very problematic for HIDs since they used a switched ground to go from low beam to high beam. I don't deal with Lumens brand so I cannot confirm 100% that their H4 relay harness will work in your Subaru but we carry Morimoto bi-xenon relay harnesses that can do it. Try swapping the pins around on the Lumen relay harness to see what works properly, there are 9 possible positions the wires can be in, try all 9!

                    2. The HID bulb that is not working, either the bulb or ballast is dead or you simply have the connectors from the relay harness going into ballast flipped around, try flipping the connector a full 180 degrees to reverse the polarity of power going into the ballast.

                    OR stop by the shop for a diagnosis appointment and or full install :) 885 Redonda Street Unit 9

                    thanks man i already found out the problem, there was a short in the high low module to begin with, and because the unit has a closed module i couldn't check the wiring, changed out to the new high/low harness everything is working good.

                    edit: anyway you can inbox me for a retrofit pricing on my gc8?

                      August 01, 2016, 10:51 PM #10

                      WinnipegHID Offline

                      • Regular Member
                      • Posts: 40
                      • Join Date: Jan 2014
                        Location: Winnipeg, MB
                      • Real Name: Tom
                      • Reputation Power: 1
                      • WinnipegHID has no influence.
                      Originally posted by Jmacs
                      thanks man i already found out the problem, there was a short in the high low module to begin with, and because the unit has a closed module i couldn't check the wiring, changed out to the new high/low harness everything is working good.

                      edit: anyway you can inbox me for a retrofit pricing on my gc8?

                      Oh ok awesome! Good job on the fix.

                      If you're wanting to retrofit HID projectors I'd definitely suggest a set of the new Morimoto Mini H1 7.0 bi-xenon HID projectors. They'll bolt right onto the GC8 headlights with minimal modifications to the housings, making the retrofit process pretty much as easy as it can get. Using the Mini Gatling Gun shrouds will also make the retrofit super simple or you upgrade to a full size shroud but that will require some trimming to make them fit in the headlights.

                      Morimoto Mini H1 7.0 Bi-Xenon HID Projectors are $150 CAD + tax for a set.

                      Mini Gatling Gun shrouds are $25 per pair or full size shrouds are $45 per pair.

                      Automotive Lighting Upgrade & Repair Specialists

                      Explore & purchase products online SOON: www.winnipeghid.ca

                      - Custom Built Headlights
                      - HID Projector Retrofitting
                      - HID & LED Conversions
                      - Custom DRL Setups
                      - Headlight Lens Restorations
                      and more!...

                      885 Redonda Street Unit 9

                        August 05, 2016, 03:35 PM #11

                        Jmacs Offline

                        • Regular Member
                        • Posts: 212
                        • Join Date: Jun 2012
                          Location: Winnipeg, Manitoba
                        • Real Name: Julian Macaraeg
                        • Vehicle: GT86 2013 - Whiteout // AE86 1987 Panda
                        • Reputation Power: 4
                        • Jmacs has no influence.
                        Originally posted by WinnipegHID
                        Oh ok awesome! Good job on the fix.

                        If you're wanting to retrofit HID projectors I'd definitely suggest a set of the new Morimoto Mini H1 7.0 bi-xenon HID projectors. They'll bolt right onto the GC8 headlights with minimal modifications to the housings, making the retrofit process pretty much as easy as it can get. Using the Mini Gatling Gun shrouds will also make the retrofit super simple or you upgrade to a full size shroud but that will require some trimming to make them fit in the headlights.

                        Morimoto Mini H1 7.0 Bi-Xenon HID Projectors are $150 CAD + tax for a set.

                        Mini Gatling Gun shrouds are $25 per pair or full size shrouds are $45 per pair.



                        what are you guys looking for installed?

                          August 07, 2016, 07:16 PM #12

                          WinnipegHID Offline

                          • Regular Member
                          • Posts: 40
                          • Join Date: Jan 2014
                            Location: Winnipeg, MB
                          • Real Name: Tom
                          • Reputation Power: 1
                          • WinnipegHID has no influence.
                          Originally posted by Jmacs
                          what are you guys looking for installed?

                          Full installation could add around $200.
                          Automotive Lighting Upgrade & Repair Specialists

                          Explore & purchase products online SOON: www.winnipeghid.ca

                          - Custom Built Headlights
                          - HID Projector Retrofitting
                          - HID & LED Conversions
                          - Custom DRL Setups
                          - Headlight Lens Restorations
                          and more!...

                          885 Redonda Street Unit 9

                            Top Tier Imports

                            Need help with GC8 and HID's
                            « Reply #12 on: August 07, 2016, 07:16 PM »