Author Topic: 2003 Infiniti Coupe Rough Idle  (Read 168 times)

May 05, 2017, 05:21 PM #0

thomasmarzec Offline

  • Regular Member
  • Posts: 16
  • Join Date: Apr 2016
    Location: Winnipeg
  • Real Name: Thomas
  • Vehicle: '04 G35 Coupe 6MT
  • Reputation Power: 1
  • thomasmarzec has no influence.
Hi everyone,

I've been having issues with my idle lately. I knew I had to change my spark plugs so I just today installed all 6 NGK ones (one of them had oil in them which was worrisome). Anyways, I'm thinking it could be a valve cover gasket, injectors or something to do with fuel.. Any ideas would be greatly appreciated, I haven't driven the car since this issue. The car sounds like its barely running and is sputtering (please see video)

Thank you.
Last Edit: May 05, 2017, 05:24 PM by thomasmarzec

    Top Tier Imports

    2003 Infiniti Coupe Rough Idle
    « on: May 05, 2017, 05:21 PM »

    May 06, 2017, 10:00 PM #1

    themikewoo Offline

    • Regular Member
    • Posts: 8,628
    • Join Date: Apr 2012
      Location: 2537 Pembina Hwy, Winnipeg, MB R3T 2H5
    • Real Name: Jimmy Choo
    • Vehicle: 2006 Honda S2000
    • Reputation Power: 191
    • themikewoo is awe-inspiring!themikewoo is awe-inspiring!themikewoo is awe-inspiring!themikewoo is awe-inspiring!themikewoo is awe-inspiring!themikewoo is awe-inspiring!themikewoo is awe-inspiring!themikewoo is awe-inspiring!themikewoo is awe-inspiring!themikewoo is awe-inspiring!themikewoo is awe-inspiring!themikewoo is awe-inspiring!

    May 10, 2017, 09:20 PM #2

    J_mullet Offline

    • Regular Member
    • Posts: 19
    • Join Date: Aug 2015
    • Reputation Power: 4
    • J_mullet has no influence.
    Hey! I just struggled through this with my 04.5 coupe. Tried lots of stuff, coils, plugs, checked compression, spark etc. Let me know your codes. You can get the ecu to flash the engine code long/short flashes if you don't have a code reader. Let me know the codes you got, if they're the same I probably will have a fix for you.
     

      May 11, 2017, 04:45 PM #3

      thomasmarzec Offline

      • Regular Member
      • Posts: 16
      • Join Date: Apr 2016
        Location: Winnipeg
      • Real Name: Thomas
      • Vehicle: '04 G35 Coupe 6MT
      • Reputation Power: 1
      • thomasmarzec has no influence.
      Originally posted by J_mullet
      Hey! I just struggled through this with my 04.5 coupe. Tried lots of stuff, coils, plugs, checked compression, spark etc. Let me know your codes. You can get the ecu to flash the engine code long/short flashes if you don't have a code reader. Let me know the codes you got, if they're the same I probably will have a fix for you.
       

      Thanks for the reply man. I don't currently have a CEL when I power on my car, HOWEVER, one day when I started it; the CEL was flashing on and off for about thirty seconds. I had a code before, I think it was p0355 or something but that was months back.

        May 11, 2017, 04:55 PM #4

        J_mullet Offline

        • Regular Member
        • Posts: 19
        • Join Date: Aug 2015
        • Reputation Power: 4
        • J_mullet has no influence.
        My codes were p0021 cam position sensor timing over advanced, and p0300 multiple misfires. The issue ended up being the vvt selinoid sticking open. So after 2000 rpm kinda like vtech or something like it, selinoid opens. Then when it went back to idle, the cam would behave as if it was full throttle above 2000rpm. Blah blah blah

        So the fix that worked for me was opening up the selinoid, spraying it down with wd-40 like crazy and rotating a cylinder type thing attached the the selinoid wish screens on it and whatnot until it was free. Put it back in and I got vtech back yo. I wasted a bunch of time, and money on parts. Hopefully this is the fix for you too.

        Let me know how it turns out or if you have questions.

          May 11, 2017, 09:25 PM #5

          J_mullet Offline

          • Regular Member
          • Posts: 19
          • Join Date: Aug 2015
          • Reputation Power: 4
          • J_mullet has no influence.
          For me, after I replaced the cam position sensor it was fine, took it for a drive, came home and idle was messed up again. Partially out of frustration I hammered on the selinoid and soon as I did, the idle smoothened out. At this point I knew it was sticking.

            Top Tier Imports

            2003 Infiniti Coupe Rough Idle
            « Reply #5 on: May 11, 2017, 09:25 PM »